Support

Please note that Seismovision 1, 2 and 3 are no longer supported!

The most common problem is having an outdated version of Seismovision. Make sure you have the latest version and if the problem persists, simply contact me.

There are multiple ways for you to get support for Seismovision. Click on a method below to suit you. All contacts must be made in English or German (Deutsch).

I recommend posting on the forum, when anyone else has the same problem/comment/suggestion, they can read up on what happened so far. You will have to register to make posts on the forum. Please only post about Seismovision related stuff. Spam posts or other inappropriate posts WILL be deleted!

Be Sociable, Share!